Recent Posts

Pages: « 1 2 3 4 5 6 7 8 9 10 »
ReHIPS / Re: MS Office programs hanging
« Last post by Statistically long odds on September 07, 2020, 07:27:31 pm »
It sounds like an issue with user permissions. I suggest checking what the MS Office processes try to get access to with something like Sysinternals Process Monitor. In particular, the file operations that get an "ACCESS DENIED" result.
ReHIPS / Re: MS Office programs hanging
« Last post by shmu26 on September 07, 2020, 03:42:06 pm »
The MS Office programs don't visibly crash. They don't even launch at all. This only happens when isolated. Otherwise, they work fine.
ReHIPS / Re: MS Office programs hanging
« Last post by Statistically long odds on September 05, 2020, 10:27:06 pm »
Do your programs just hang and do nothing except appearing in the task manager? Or do they crash on launch with a “failed to start isolated program” message?

ReHIPS seems to cause the first problem quite often on my end (32-bit Windows 7 SP1), even with no other security solution installed, and even in Disabled mode. Programs — isolated or not — randomly hang on launch, forcing me to shut them down with a task manager. A minor inconvenience most of the time, but it makes me wary of building a huge program/library in MinGW.

Only disabling the ReHIPS service and its driver seems to circumvent that problem. Honestly, it is about the only thing that keeps me from switching from Sandboxie to ReHIPS on my desktop computer.

I have yet to encounter a program that always hangs like that though.
ReHIPS / Re: MS Office programs hanging
« Last post by shmu26 on September 04, 2020, 10:41:06 am »
ReHIPS / MS Office programs hanging
« Last post by shmu26 on August 31, 2020, 08:11:28 pm »
I installed ReHIPS 2.4.0 in a Windows 7 virtual machine.
I have MS Office Standard 2016 on the VM, and the Office apps hang, they don't finish launching. This happens whether or not I use the main desktop.
AV is ESET, default settings.
I disabled Hard_Configurator, which is my other security program, but that didn't help.

ReHIPS / Re: Ask Questions Here - ReHIPS Features & Unexpected Behaviors
« Last post by RocksoftLtd on August 30, 2020, 09:47:21 pm »
Original message deleted as developer had already replied via email message that was missed. Thanks
ReHIPS / ReHIPS and Shadow Defender
« Last post by Stephen on August 07, 2020, 09:17:04 am »
Has anybody tried this a combination of ReHIPS and Shadow Defender?

Are there any benefits or disadvantages? Does the PC performance suffer from such an arrangement?

Please note that I have no experience with Shadow Defender, but I have always been curious about how it works and I didn't find any recent discussion in the forum.
ReHIPS / Re: Ask Questions Here - ReHIPS Features & Unexpected Behaviors
« Last post by winuser on August 06, 2020, 03:28:54 pm »
hi, I was very busy during the last few months and I think you were right ( I use a modified Default.rdb )

anyway, I think ReHIPS "Network Protection" (or whatever it's called) is not compatible with some VPN software. I use ProtonVPN and whenever ReHIPS is enabled, ProtonVPN shows the following error message:
BUT when I run "net stop ReHIPSService" it can successfully connect to the same server.
ProtonVPN has a free plan so you can easily check it out on your test machines.

ReHIPS v2.4 (Demo)
ProtonVPN v1.16.3
Windows 8.1 (it happens on windows 7 too)
ReHIPS / Copy User Data enable and then disable?
« Last post by Stephen on August 03, 2020, 08:09:43 am »
After re-installing Windows and programs the folloing question has come to mind. I read the FAQ on the Copy User Data feature and I'm wondering if I understand it correctly. After enabling Copy User Data and if everything works fine, should we then disable it? If so, I've not been using it as I should!

A second question concerns how to update User Data. Is it a simple matter of enabling this feature or should something more involved be done, for example deleting the appropriate ReHIPS User folder?
ReHIPS / Re: questions about Administrator mode and bug in the deploy heller?
« Last post by fixer on July 05, 2020, 05:11:29 pm »
Hello, Osmw.
Welcome to our forum and thank you for your interest in our product.

I don't see anything wrong in your description of installed software. It required Administrator rights, so most likely was installed into Program Files and thus it's in the list of installed programs. Desktop shortcut (along with some other shortcuts) is usually copied by DeployHelper for your usability. You can launch it... it's supposed to be this way, no? The main question is when you start it, does it start isolated by default? If yes, then it's OK, it was installed into isolated environment and is started in it.

Regarding Administrator rights. DeployHelper is not for security purposes. It's for usability, it doesn't provide protection and it expects programs to behave. So it's OK to run them with Administrator rights. Especially since some installers refuse to install under user accounts. Running programs in isolation on the other hand is for security. And this security is based on Windows built-in principle of users separation from each other and from OS. And trying to start them with Administrator rights here may bring damage. And ReHIPS will try to stop you from doing this.
Pages: « 1 2 3 4 5 6 7 8 9 10 »