Uninstalling a program after disabling its services had problems

Started by maskelilincoln, January 17, 2022, 11:36:34 PM

Previous topic - Next topic


Your Unistall software needs to check for Rehips services and install them if they are not.
I guess it doesn't do that so it had trouble uninstalling the program. Because services were disabled at that time


This is how things happened

1.There was a problem with my computer I disabled the Rehips software to find out what software it was causing
2.The problem still persisted I noticed that the services of the rehips software were not disabled, I deleted them
3.Again, the problem of my computer continued, I tried to remove the rehips software, because I deleted the services, the removal did not work properly.

This is how everything happened

I realized that my computer's problem is not from rehips software but that's not what I'm reporting to you


Quote from: maskelilincoln on January 17, 2022, 11:42:07 PM
the removal did not work properly
1. And what exactly wrong happened?
2. There are actually 2 services: ReHIPSService and ReHIPSSrvc - for user-mode service and for driver. Did you delete both of them or just one (which?)?


I deleted both so I couldn't uninstall the rehips software.

So you need to add a services check to the uninstaller.


Steps we tried:
1. Disable ReHIPS from main GUI window in Control Center.
2. Close Control Center.
3. Disable both services.
4. Delete both services.
5. Uninstall ReHIPS.
Everything went fine. In theory it shouldn't cause any problems as one of the first things the uninstaller does is stopping and deleting both services.

0. Did we miss something? Or any way to reproduce it?
1. Are you sure you're using the latest 2.5.0 release?
2. What exactly went wrong? What was the problem?