[UNDER REVIEW] Feature Request - Ability to Export\Import ReHIPS Config

Started by HJLBX, April 06, 2016, 12:55:55 AM

Previous topic - Next topic


we definitely need this feature, because coying just the xml.file may create issues, explanation:

1- go on my admin accoount
2- copied Rehips.xml

then i rollback to a snapshot without ReHIPS

3- I went to my admin account
4- installed ReHIPS (denied initial rules installation, i have them already in xml file), didn't launch ReHIPS.
5- i went to ReHIPS folder, copied the xml files which, in my case, generated an UAC prompt.
6- launched ReHIPS, check the rules, they are present.
7- rebooted.
8- tried to launch Chrome isolated (by clicking its icon) and then :

9- at that point , i had to go to the GUI > Setting > Programs > then delete the Browser rules of my current user (in my case Chrome in Umbra) as below:

the Tray icon became red, the GUI froze for few seconds then both tray icon and GUI went back to normal.

10- at this point , i had to click on the Install Rules button , then REHIPS  recreated clean rules and the error was fixed; and i was able to run the browser isolated normally.


Me too. In fact many of us utilize drive snapshots to restore to a previous state or Shadow Defender on every reboot.


I guess it's because ReHIPS users weren't properly created. And I think all these issues can be solved by RulesManager and custom set of rules. We've got both in our TODO list.



ok i found a workaround for importing the rules "properly", check this thread: https://forum.re-crypt.com/index.php?topic=2450.0