Author Topic: libreoffice doesn't start  (Read 3889 times)

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
libreoffice doesn't start
« on: June 09, 2016, 06:54:23 pm »
and in log there is no clickable option
see attached log

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #1 on: June 09, 2016, 07:05:57 pm »
Setting it up in vm in a bit to check and see if i can reproduce it or something. Do you use version 5.1.3?

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #2 on: June 09, 2016, 07:07:37 pm »
v 2.2

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #3 on: June 09, 2016, 07:12:12 pm »
Can you link me where to download it from. I checked their site and they only had 5.1.3 and 5.0.6.
Also you might want to mention your OS if it's a specific to the issue.
« Last Edit: June 09, 2016, 07:15:03 pm by aDVll »

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #4 on: June 09, 2016, 07:18:08 pm »
my bad, I thought you were asking which version of rehips.
I am on libreoffice 5.1.2 (that is what the installation file says anyways, I can't actually open the program and check)
I will upload the installation file to OneDrive, so I can send you a link

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #5 on: June 09, 2016, 07:21:42 pm »
I got 5.1.3 and it works just fine btw.  Rehips even made the rules for it. Did you by any chance change the setting in the rehips rules for libreoffice?
Try this to start with. Go in rehips and find the rules called libreoffice and delete that. Then go on main gui and click install rules. Wait for rules to finish(takes a few min) and see if that fixes it.

What OS do you have?
« Last Edit: June 09, 2016, 08:29:25 pm by aDVll »

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #6 on: June 09, 2016, 08:40:45 pm »
windows 10 x64
sorry for stupid question from a beginner, but how do I find the rules?
I don't think I changed the rule, because I couldn't figure out how to do that.

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #7 on: June 09, 2016, 08:53:24 pm »
Hmm i also use windows 10 64 bit so even better. To start do you use any other application because some need to allow rehips(i think you use NVT or VS which then you will need to allow a few stuff of rehips)? If yes disable them and try to launch libreoffice again.

Now the steps to reinstall rules.
Open rehips gui, click settings, click on the 3rd tab called Programs. There you see one called SYSTEM and another one with your pc account name. Expand the account username by clicking the little arrow to the left of it. There you will see one called Libreoffice.  Click on that and then hit delete on your keyboard.
After that click ok and go in main rehips gui windows. Click install rules and wait until you get a msg that rules are installed(takes a few minutes).
When it's done try to launch libreoffice again.

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #8 on: June 09, 2016, 08:59:01 pm »
I uninstalled NVT ERP before installing rehips.
but I have webroot secureanywhere (now disabled)
and hitmanpro.alert (exploit mitigation now disabled)
and libreoffice still does not start.
I will now check out the rules.

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #9 on: June 09, 2016, 09:11:57 pm »
okay, after deleting rule and reinstalling rules, I at least got a pop-up message that Libre is blocked. That's semi-normal behavior.
I unblocked it, and it opened in a separate desktop.
I allowed it, and it opens non-sandboxed.
Still can't hit that sweet spot of opening sandboxed on regular desktop.

by the way, how can you add attachments to a post, when the browser is sandboxed?

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #10 on: June 09, 2016, 09:16:10 pm »
okay, after deleting rule and reinstalling rules, I at least got a pop-up message that Libre is blocked. That's semi-normal behavior.
I unblocked it, and it opened in a separate desktop.
I allowed it, and it opens non-sandboxed.
Still can't hit that sweet spot of opening sandboxed on regular desktop.

by the way, how can you add attachments to a post, when the browser is sandboxed?
You said it opened in a separate desktop and that's what it should do. Then you said it opened non sandbox. You closed the seperate desktop and started libre again? What blocked it btw you said all are disabled?
Oh now that i understood. You wanted libreoffice to open on the same desktop not a different one?

Browsers have access to C:\ReHIPS\Browser so you need to put the thing you want to attach there. Then when you are attaching browse to the location and it should work.

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #11 on: June 09, 2016, 09:23:48 pm »
"You said it opened in a separate desktop and that's what it should do. Then you said it opened non sandbox. You closed the seperate desktop and started libre again? What blocked it btw you said all are disabled?
Oh now that i understood. You wanted libreoffice to open on the same desktop not a different one?"

after reinstalling rules, it was blocked.
when I went to the blocked tab and unblocked it, it then opened in separate desktop.
when I went to the isolated tab and allowed it, it then opened unsandboxed.

yes, I would like it to open sandboxed, but on my regular desktop, the way firefox does.

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #12 on: June 09, 2016, 09:29:51 pm »
Programs that need hook control are launched at separate dekstop for security reasons.
You can check if it works without doing this steps i will write below. I must note that some stuff in libreoffice may or may not work doing this. Please tell me if you find something not working after doing this.

Do the same things i told you before to find the libreoffice rules and delete it. But this time don't delete but double click on the name. You will see a new box and at the bottom it has some arrows. Expand that, go on the second tab called privileges and deselect Use Seperate Desktop and DESKTOP_HOOKCONTROL and click ok. Launch libreoffice now and it should launch like Firefox.

shmu26

  • Active Testers
  • Sr. Member
  • *****
  • Posts: 436
  • Win10 x64 latest stable
Re: libreoffice doesn't start
« Reply #13 on: June 09, 2016, 09:40:31 pm »
that worked.
pretty good!
now I will try get my abode pdf reader to work. same basic problem.

aDVll

  • Active Testers
  • Hero Member
  • *****
  • Posts: 1119
  • Windows 10 latest 64 bit
Re: libreoffice doesn't start
« Reply #14 on: June 09, 2016, 09:42:37 pm »
that worked.
pretty good!
now I will try get my abode pdf reader to work. same basic problem.
Adobe will not work without hook control so the only way to launch on the same desktop is to accept the "small" security risk and only deselect Use Different Desktop.